Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(13)

Issue 5254061: code review 5254061: gotest: avoid conflicts with the name of the tested package (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
13 years, 5 months ago by Esko Luontola
Modified:
13 years, 5 months ago
Reviewers:
CC:
golang-dev, r2, adg, rsc
Visibility:
Public.

Description

gotest: avoid conflicts with the name of the tested package Uses a generic solution of renaming the tested package, instead of using cryptic names for all other imports, variables and methods in the generated _testmain.go file. Fixes issue 2346.

Patch Set 1 #

Patch Set 2 : diff -r 2ed5badf6599 https://go.googlecode.com/hg/ #

Patch Set 3 : diff -r 988a7f023895 https://go.googlecode.com/hg/ #

Patch Set 4 : diff -r b04a8597454c https://go.googlecode.com/hg/ #

Unified diffs Side-by-side diffs Delta from patch set Stats (+29 lines, -21 lines) Patch
M src/cmd/gotest/gotest.go View 1 2 3 5 chunks +29 lines, -21 lines 0 comments Download

Messages

Total messages: 7
Esko Luontola
Hello golang-dev@googlegroups.com (cc: golang-dev@googlegroups.com, rsc@golang.org), I'd like you to review this change to https://go.googlecode.com/hg/
13 years, 5 months ago (2011-10-12 22:49:21 UTC) #1
rsc
sut is an odd name. how about pkg and pkg_test instead of sut and sut_out?
13 years, 5 months ago (2011-10-14 16:47:38 UTC) #2
r2
On Oct 14, 2011, at 9:47 AM, Russ Cox wrote: > sut is an odd ...
13 years, 5 months ago (2011-10-14 16:58:17 UTC) #3
Esko Luontola
SUT stands for system under test, but I agree that it's not very readable name, ...
13 years, 5 months ago (2011-10-14 18:58:22 UTC) #4
Esko Luontola
Hello golang-dev@googlegroups.com, r@google.com (cc: golang-dev@googlegroups.com, rsc@golang.org), Please take another look.
13 years, 5 months ago (2011-10-14 19:20:58 UTC) #5
adg
LGTM
13 years, 5 months ago (2011-10-17 03:07:08 UTC) #6
adg
13 years, 5 months ago (2011-10-17 03:19:08 UTC) #7
*** Submitted as http://code.google.com/p/go/source/detail?r=0445521cd154 ***

gotest: avoid conflicts with the name of the tested package

Uses a generic solution of renaming the tested package, instead of
using cryptic names for all other imports, variables and methods
in the generated _testmain.go file.

Fixes issue 2346.

R=golang-dev, r, adg
CC=golang-dev, rsc
http://codereview.appspot.com/5254061

Committer: Andrew Gerrand <adg@golang.org>
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld f62528b